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Option 1 - Primary school activity 
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QUESTION: What day had the highest temperature recorded in the greenhouse? 
 
___________________________________________________________________________  
 

QUESTION: What day had the lowest temperature recorded in the greenhouse? 
 
___________________________________________________________________________  
 

QUESTION: Which was the x-axis (horizontal axis) and what did you label it? 
 
___________________________________________________________________________  
 

 

Sample data 

Date Time Humidity Temperature (inside) 
25/06/2017 12:00:00 75.9 17.7 
25/06/2017 12:05:00 77.0 17.4 
25/06/2017 12:10:00 77.0 17.3 
25/06/2017 12:15:00 78.0 16.9 
25/06/2017 12:20:00 78.0 17.0 
25/06/2017 12:25:00 78.0 16.9 
25/06/2017 12:30:00 79.0 16.7 
25/06/2017 12:35:00 78.1 16.5 
25/06/2017 12:40:00 78.0 16.7 

 

QUESTION: How frequently was data being recorded in the greenhouse? 
 
___________________________________________________________________________  
 
QUESTION: Write down what observations the farmer was making in the greenhouse? 
 
___________________________________________________________________________  
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There are ideal conditions for growing Oriental lilies. When those conditions are not met, the 
farmer receives an alert 
 
Date Humidity alert Temperature alert 
25-Jun okay okay 
26-Jun okay okay 
27-Jun okay ALERT 
28-Jun okay okay 
29-Jun okay okay 
30-Jun okay okay 
01-Jul ALERT ALERT 
02-Jul ALERT ALERT 
03-Jul okay okay 
04-Jul okay okay 
05-Jul okay okay 
06-Jul okay okay 
07-Jul okay okay 
08-Jul okay okay 
09-Jul okay okay 
10-Jul okay ALERT 

 
 
QUESTION: How many days had a “Humidity alert”? 
 
___________________________________________________________________________  
 

QUESTION: How many days had a “Temperature alert”? 
 
___________________________________________________________________________  
 

QUESTION: What should happen when there is an alert? 
 
___________________________________________________________________________ 
  
___________________________________________________________________________ 
 
___________________________________________________________________________ 

___________________________________________________________________________   
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Option 2 - High school activity 

1. Open up the “Avonlea Greenhouse dataset” in Excel and select the “Data” tab.  

In this tab is all of the greenhouse data for growing oriental lilies. 

 

Creating a Pivot Table 

A pivot table is a table of statistics that summarize the data of a more extensive table. This 
summary might include sums, averages, or other statistics, which the pivot table groups together 
in a meaningful way. For this data set, we are after the average of each variable per day. 

2. Add a new blank tab by selecting the  button next to the “Data” tab at the bottom 
of your workbook. 

 

3. Insert a pivot table. 

To do this, select the “Insert” tab, then select “Pivot table” and press “OK” 

 

 

A pop up box will appear called “Create PivotTable” 
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Click the arrow at the end of the box next to “Table/Range”. 

 

 

 

A new pop up box will appear. 

 

Now, select all the data in the “Data” tab 
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On the right hand side of your screen, the “PivotTable Fields” table appears as below 
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4. Create your pivot table 

In the top section, check the boxes next to “Date”, “Month”, “Humidity” and “Temperature 
(inside)”.  

Make sure all the others are unchecked. 

 

 

For the four fields in the bottom section make sure your categories are as follows 

 

 

You will notice that when you check humidity and temperature Excel will automatically put 
them in to the “Values” field as “Sum of Humidity”, etc.  

 

For this analysis we do not want “Sum of…” but rather “Average of…” 

 

Notes: 

You can move selection criteria to 
another field by dragging and dropping 
the selection criteria from one field to 
another. 

You can also have a selection criteria in 
more than one field by clicking on the 
criteria in the top box (with check 
marks) and dragging it down to the 
second field box you want it in. 
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To update the variable from Sum to Average. 

Select the arrow next to the selection criteria (eg. “Sum of Humidity”)  

 

 

Select “Value Field Settings” at the bottom of the list. 

 

 

A pop up window will appear. Select “Average” in the list, then “OK” 
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Your excel worksheet will now look like this 
 

 
 
To view all of the dates, select the “+” sign to the left of “Jun” and “July” 
 
 
Now you can visualise the average humidity and temperature recordings for each of the 
days recorded. 
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Note:  
If your data does not look like this, your “Rows” in the “PivotTable Fields” may be around 
the wrong way. Make sure that “Months” is above “Date” and if not drag one above or below 
the other. 
 
 
 

5. Open and label a new tab (for your pivot table data) called “Summary data” 
 
Highlight all the data in your pivot table, copy and “paste as values” into your new tab  
 
(right click and select “paste as values”) 

 

 

 

 

 

 

 

 

6. Remove the rows “Jun”, “Jul” and “Grand Total” 

 

Note: 

Delete multiple rows by clicking the row number for each row you want to delete. You can 
select multiple rows by holding down “Ctrl” as you select them. Once selected, right click 
your mouse and select “Delete” 
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Graphing your data 

Next we will create a scatter with straight line and markers graph plotting temperature and 
humidity over time. 

1. Insert a scatter graph 

Select all the data in your new tab. 

Then select “Insert” and click on the Line Graph icon 

 

 

Then select the “Line with markers” option 
 

 
 

2. Add a secondary axis 

We want the humidity data to be on a different axis to the temperature data.  

To do this click on your graph and select the humidity data line so that it is highlighted. 

Then, select the “Design” tab and select “Change Chart Type” 
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A pop up window will appear. Check the “Secondary Axis” check box next to “Average of 
Humidity” 

 

Select “OK” 

Your graph should look similar to this. 
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3. Add axis titles to graph 

To add axis titles to your graph, click on your graph, select the + symbol at the top right corner. 

Select “Axis titles”  

 

Give your “Chart”, “X” and “Y” axes appropriate titles. 

Hint: Think about what your column names are and what you have graphed.   
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Identifying imperfect growing conditions 

Humidity and temperature are controlled in the greenhouse in order to grow oriental lilies.  

The ideal growing conditions for oriental lilies are 

• Humidity: 70-80%, max of 95% 
o We are going to create an alert if the humidity is < 72% 

• Temperature: 18-21°C, min of 15°C, max of 26°C 
o We are going to create an alert if the temperature < 17.5C 

Using the ideal conditions above, we can create some alerts in Excel to advise us when these 
conditions were not met. 

 

1. Add new columns 

For our graphed dataset, add two column headings 

Column D = “Temperature Alert” 

Column E = “Humidity Alert” 

Also, rename Column A from “Row Labels” to “Date” 

 

2. Calculate an alert for Temperature 

To do this we need to create an equation which can identify when the temperature falls below 
17.5C. 

These statements are called “IF” statements and allow us to make a comparison between a 
value and what that value actually means. 
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How do IF statements work? 

An IF statement is like a yes/no or TRUE/FALSE question.  

They are known as a type of ‘logical formula’:  

IF, then, else 

IF something is true, THEN do this, ELSE do that. 

In Microsoft Excel, IF statements are made up of three parts: the statement, a value to return if 
TRUE, and a value to return if FALSE 

In our example above,  

=IF(C3=C2, “”,C3) 

We are comparing one value in the ‘hour’ column (cell C2) to the value in the row above it (cell 
C3). 

IF the values are the same, THEN the formula will return a blank cell (designated as “”).  

IF the values are different, ELSE the formula will return the hour value in cell C2. 

 

Another example of an “IF” statement is marking an assessment where a student either gets less 
than 50 and they fail, or higher than 50 and they pass. 
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In regard to the temperature of our greenhouses we expect that if temperature is below 17.5C 
then this is not an ideal growing conditions for Oriental lilies.  

Our alert with the “IF” statement, will tell us on which days temperature was “okay” and which 
days the temperature was not and the farmer should be alerted to go and check on the 
greenhouse. 

 

In Cell D2 type =IF(B2<17.5,"ALERT", "okay") 

 

After typing in the formula in cell D2, press enter and copy the formula into the remaining cells. 

You can copy a formula by clicking on the cell, then clicking on the green square in the bottom 
right hand corner of the cell and dragging down to the last cell you want to copy the formula to 
(in our case cell D17). 

 

You should have something that looks like Column D below. 
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3. Calculate an alert for humidity 

Repeat for humidity where  

In cell E2 type =IF(C2<72,"ALERT", "okay") 

After typing in the formula in cell E2, press enter and copy the formula into the remaining cells 
in column E. 

 

Have a look at your data and identify if there were any days were temperature or humidity 
were not at the ideal growing conditions. 
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Data analysis questions 

 
QUESTION: How frequently was data being recorded in the greenhouse? 
 
___________________________________________________________________________  
 
QUESTION: Write down what day/s received an “alert” 
 
Humidity alert Temperature alert 
  

 
 
 
 
 

  
QUESTION: How many days had a “Humidity alert”? 
 
___________________________________________________________________________  
 

QUESTION: How many days had a “Temperature alert”? 
 
___________________________________________________________________________  
 
QUESTION: Where there any days that look abnormal on your day (Hint: see if there were any 
days with a high or low humidity or temperature reading). If so, when? 
 
___________________________________________________________________________  
 
___________________________________________________________________________  
 
___________________________________________________________________________  
 

QUESTION: Did these days match your “alerts”? 
 
___________________________________________________________________________  
 
QUESTION: How can data and alerts be used to assist producers manage their crop or flower 
production? 
 
___________________________________________________________________________  
 
___________________________________________________________________________  
 
___________________________________________________________________________  
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QUESTION: List all of the applications or potential experiments you could conduct with soil, 
temperature and humidity sensors: 

• ________________________________________________________________________ 
 

___________________________________________________________________________ 
 
• ________________________________________________________________________ 

 
___________________________________________________________________________ 
 
• ________________________________________________________________________ 

 
___________________________________________________________________________ 
 
• ________________________________________________________________________ 

 
___________________________________________________________________________ 
 
• ________________________________________________________________________ 

 
___________________________________________________________________________ 
 


